La marelle (partie 1)

Publié le

On veut programmer un jeu de marelle sur le logiciel ALGOBOX. La marelle est un jeu enfantin où le joueur doit lancer une pierre sucessivement dans la case 1, 2, 3, 4,…

Pour simuler un lancer de pierre, ALGOBOX va prendre un nombre aléatoire entre 1 et 9 (case 1-8 + case ciel). On simule 200 lancers dans une liste L.

Ensuite, on repère les lancers 1 dans la liste L et on met l’indice de placement des 1 dans une nouvelle liste A.

On affiche enfin la suite des 9 lancers avec comme début 1.

VARIABLES

L EST_DU_TYPE LISTE

A EST_DU_TYPE LISTE

k EST_DU_TYPE NOMBRE

i EST_DU_TYPE NOMBRE

DEBUT_ALGORITHME

POUR i ALLANT_DE 1 A 200

DEBUT_POUR

L[i] PREND_LA_VALEUR ALGOBOX_ALEA_ENT(1,9)

FIN_POUR

AFFICHER*  »  »

k PREND_LA_VALEUR 1

POUR i ALLANT_DE 1 A 200

DEBUT_POUR

SI (L[i] == 1) ALORS

DEBUT_SI

A[k] PREND_LA_VALEUR i

AFFICHER A[k]

AFFICHER  »  »

k PREND_LA_VALEUR k+1

FIN_SI

FIN_POUR

AFFICHER*  »  »

k PREND_LA_VALEUR k-1

POUR i ALLANT_DE 1 A k

DEBUT_POUR

AFFICHER L[A[i]]

AFFICHER  »  »

AFFICHER L[A[i]+1]

AFFICHER  »  »

AFFICHER L[A[i]+2]

AFFICHER  »  »

AFFICHER L[A[i]+3]

AFFICHER  »  »

AFFICHER L[A[i]+4]

AFFICHER  »  »

AFFICHER L[A[i]+5]

AFFICHER  »  »

AFFICHER L[A[i]+6]

AFFICHER  »  »

AFFICHER L[A[i]+7]

AFFICHER  »  »

AFFICHER L[A[i]+8]

AFFICHER*  »  »

FIN_POUR

FIN_ALGORITHME

Le score maximal de la marelle est le plus grand nombre de termes succesifs [1,2,3,4,5,6,7,8,9] sur toutes les listes avec un 1 au début.

Exemple :
1 3 4 2 1 4 3 2 5

1 4 3 2 5 3 8 7 5

1 2 3 5 8 4 3 2 1

Dans cette partie, le score maximal est 3 car on retrouve 1 2 3 dans la dernière liste avec un 1 au début.

Dans la seconde partie de l’article, nous allons compléter l’algorithme pour obtenir le score maximal.

Publicités

Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s